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3D Data Hack Dublin

• The following guide has been prepared as part of the Building City Dashboard project, 
a Science Foundation Ireland initiative based at Maynooth University, Ireland.

• The guide outlines how the resources provided for the 3D Data Hack Dublin can be 
used with a game engine to facilitate real-time interaction and visualization.

• Following the guide is expected to take between 45 mins and 1 hr 30 mins to complete.

• This guide is not intended as a comprehensive instruction manual.

• It has been provided to help those who are new to real-time, interactive visualisation
to get up and running quickly so that they can start exploring their own ideas.

• Suggestions for next steps are provided toward the end of the guide.

NOTE: This guide was tested with Unity version 2019.1.0f2. As functionality and menu options can change between versions, please 
be prepared to refer to online help:

• Documentation: https://docs.unity3d.com/Manual/index.html

• Forums: https://forum.unity.com/

https://docs.unity3d.com/Manual/index.html
https://forum.unity.com/
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Download the 3D Data Hack Dublin Resources

3D Data Hack Dublin Resources are available in the following location: 
https://data.smartdublin.ie/dataset/3d-data-hack-dublin-resources

https://data.smartdublin.ie/dataset/3d-data-hack-dublin-resources
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3D Data Hack Dublin Resources

• Contents
• SDZ_Model_ITM_20190424.FBX – The 3D model we will be using in this guide. This file it suitable 

for use in many 3D modelling packages such as 3ds Max or Blender, but also in game engines like 
Unity or Unreal Engine.

• SDZ_Model_ITM_Textures_20190424.zip – A folder containing textures that can be used to 
enhance the FBX model’s appearance.

• SDZ_Model_ITM_24.max (Not used in this guide) – The original Autodesk 3ds Max project used to 
assemble the 3D data in the FBX file.

• Move_File_ITM.txt (Not used in this guide) – A file describing the spatial offset (in metres) which 
has used in the 3ds Max project to bring original survey data in the Irish Transverse Mercator 
(EPSG:2157) coordinate projection system to the world origin in 3ds Max for modelling.

Technical Note:
The spatial offset described by the move file can be used to determine the real world coordinates of objects that have been 
placed in the 3ds Max project. The offset is required because 3D modelling and visualisation software has tended to use a single 
precision floating point number format to describe spatial location: https://en.wikipedia.org/wiki/Single-precision_floating-
point_format. This is commonly done to help improve computational performance, but entails a tradeoff in loss of spatial 
precision as objects move further away from the world origin (0,0,0). Simply put, single precision floating points do not provide 
sufficient precision over great enough distances to describe real world geographic coordinates. Attempting to do so can result in 
visible jitter of objects due to spatial uncertainty, or else their failure to render, resulting in a blank screen. One solution to 
enable rendering of objects with positions described in a real word geographic coordinate system is to apply an offset to their 
coordinate position that brings them back toward the world origin.

https://en.wikipedia.org/wiki/Single-precision_floating-point_format


dashboards.maynoothuniversity.ie dashboards@mu.ie @dashbuild

Preparing your files for this tutorial

• Download the FBX file and the zip file 
containing the textures.

• Unzip the textures.
• Place the FBX and textures together 

in the same folder on your computer 
(any location of your choice is fine).

• Remember the location of the folder 
as you will need to access it later to 
import the 3D model into Unreal 
Engine.

NOTE: You can download the other 
resources but they will not be used in 
this guide.
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How to get Unity

Unity: https://unity.com/

https://unity.com/
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Select a Licence
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Accept the Terms and Download Unity
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Install Unity Hub

1

2

3
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Install the latest version of Unity
1

2

Unity Hub is useful for managing 
your projects and multiple 
versions of the Unity Editor.
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You can select components to install

Unity allows you to add components to build apps for different 
platforms. You can accept the defaults for now as you can always add 
more of these components later.
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Create a new project

1

2 3

4

1. Start a ‘New’ 
project.

2. Give the project a 
name.

3. Choose the ‘3D’ 
project template.

4. Specify the location 
on your computer to 
store the project.

5. Click ‘Create 
Project’.

5
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The Unity User Interface

Scene View is 
the window 
where you 
arrange and 
view game 
objects in your 
scene.

Hierarchy Panel 
lists the contents 
of the current 
scene or ‘level’.

The Project Tab is used to manage your project and 
provides a view of your Assets folder where 3D 
models, textures and other game content are stored.

Play Button switches to the 
Game View and allows you 
to test your scene.

Inspector Tab 
displays the 
properties of 
selected game 
objects.
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Create a new 3DModels folder

1. Right Click in the assets 
panel at the bottom of the 
screen.

2. Hover the mouse over 
‘Create’.

3. Select ‘Folder’.

4. Name the new folder 
‘3DModels’.

This will help you find and 
manage your imported 
models in the Project Tab.

1

2 3

4
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Import 3D Model

1. Right Click on your 
‘3D Models’ folder in 
the Project Tab.

2. Select ‘Import 
New Asset’.

3. Select the downloaded 
FBX model and all of the 
accompanying texture 
files and click ‘Import’.

NOTE: You do not need 
the .max file in Unity. Also 
be aware that the .FBX 
file you download may 
have a different name to 
that pictured.
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Generate Colliders for the model geometry

1. Select the imported 
FBX model from the 
3DModels folder in the 
Assets panel.

2. Select the 
‘Model’ tab.

3. Check ‘Generate Colliders’.

NOTE: This step enables objects in your scene to physically interact with each other. In 
basic terms it prevents your player walking through walls or falling through the floor.

4. Ensure you Click ‘Apply’ 
to make the changes.
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Unpack the materials embedded in the model

3. For ‘Location’ Select ‘Use 
External Materials (Legacy)’.

RESULT: This will create a 
new Materials folder inside 
the 3DModels folder 
containing editable versions 
of the 3D models materials.

1. Ensure the imported FBX 
model from the 3DModels 
folder is still selected.

4. Click ‘Apply’.

2. Select the ‘Materials’ tab.
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Drag the 3D Model into your scene hierarchy

2. Once the 3D model 
has been dragged into 
the hierarchy panel it 
should appear in your 
‘Scene’ window.
The model’s pivot in 3D 
spaces should be at the 
following coordinates: 
X=0, Y=0, Z=0.

1. Drag the 3D model 
directly into the hierarchy
from your assets collection.
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Download Unity Standard Assets

1. Click on the ‘Asset Store’ tab. 2. Search for ‘Standard Assets’
in the input field.

3. Click ‘Download’ 
and then ‘Import’ 
when prompted.

4. Click ‘Import’ in 
the ‘Import Unity 
Package’ popup.

NOTE: If you can’t see the Asset 
Store tab you can open it from the 
menu bar at the top of the screen: 
Window > Asset Store
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Add the first person character to your scene
1. Delete the ‘Main Camera’ from the hierarchy as the 
first person character will have its own camera attached.

4. Ensure the FPSController
prefab is placed above the 
ground plane otherwise it 
will fall through the floor. 
You can position it by 
entering coordinates in the 
Inspector Panel or by 
dragging the object directly 
in the Scene View using the 
red, green and blue arrows.

2. Navigate the Standard Assets
folder to find the FPSController
prefab.

3. Drag-and-drop the FPSController
prefab into the Hierarchy.
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Press Play to test your scene

Press ‘Play’ to test your scene. 
Pressing the ‘Esc’ key will allow 
you to press the play button 
again to exit play mode mode.

While in play mode you can 
navigate your scene using 
WASD keys, cursor keys, and 
the mouse.
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Save your Scene(s) as you update them

1. From the menu bar Select 
File > Save Scene

3. The Scene will be saved in 
your Asset folder. You can 
change between scenes by 
clicking on them.

2. In the ‘Save Scene’ popup 
provide a name and click 
‘Save’.
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Save the Overall Project

From the menu bar Select 
File > Save Project. This 
ensures that project wide 
setting and changes are 
saved, not just the changes in 
a particular scene.
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Save the Overall Project

1. You are now ready 
to build your game. 
From the menu select:
File > Build Settings

2. Make sure you ‘Add 
Open Scenes’ and select 
the particular scene[s] you 
want to include in the build.
3. Choose the platform you 
want to build for e.g. PC or 
Mac.
4. Choose x86 for 32-Bit or 
x86_64 for 64-Bit builds.
5. Click ‘Build’ and choose a 
file output location.
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Run your application .exe to test

NOTE: Pressing the ‘Esc’ key on your keyboard will close the application
if you add the Escape scripst outlined later in this guide.
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Trouble Shooting

• My character controller passes through the floor or walls when I press play
• Ensure that the character controller is positioned fully above the ground plane.
• Check that you correctly generated colliders for your models when you imported them as indicated earlier in the guide.

• I can’t exit the application I built
• Add the ‘Escape’ script to your project that is outlined further on in this guide. 

• The model doesn’t look how I’d expect
• Experiment with the Unity Post Processing Stack as outlined later in this guide.
• Try adjusting the model’s materials and experiment with the ‘Normal’ maps provided for some of the textures: 

https://docs.unity3d.com/Manual/StandardShaderMaterialParameterNormalMap.html

• I can’t edit the materials on my model or they appear to be missing
• Not all of the buildings in the model have photoreal textures for their facades.
• Ensuring that you selected ‘Use External Materials’ when you imported the model should ensure the inclusion of any textures for 

those buildings that do have them. This will enable you to edit and adjust all of the materials that come with the model: 
https://docs.unity3d.com/Manual/Shaders.html

• Trees and Railings look like billboards when they should be transparent
• Use the process for adding transparency outlined later in this guide.
• Alternatively you could try to create your own shader.

• My Trees or Railing are only visible from one side
• Apply a double sided shader like the Ciconia Double Sided shader indicated later in this guide.

https://docs.unity3d.com/Manual/StandardShaderMaterialParameterNormalMap.html
https://docs.unity3d.com/Manual/Shaders.html
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Further ways to enhance your scene

• Look at the other assets in the Standard Assets collection and use them to 
enhance your scene: https://assetstore.unity.com/packages/essentials/asset-
packs/standard-assets-32351

• Use other free assets from the Unity Asset Store: https://assetstore.unity.com/

• Use shaders and take advantage of the Unity Post Processing Stack to improve 
the visual appearance of your scenes. Examples follow in subsequent slides.

• Add interactivity and further functionality through scripting in the C# language. 
A very brief but useful example follows on the next slide.

• Experiment with AR and VR in Unity.

• Make use of the extensive learning materials and tutorials provided on the Unity 
website: https://unity.com/learn

https://assetstore.unity.com/packages/essentials/asset-packs/standard-assets-32351
https://assetstore.unity.com/
https://unity.com/learn


dashboards.maynoothuniversity.ie dashboards@mu.ie @dashbuild

Add a script to close your built desktop 
application with the Escape key (1)

1. Right Click in the assets 
panel at the bottom of the 
screen.

2. Hover the mouse over 
‘Create’.

3. Select ‘C# Script’.

4. Name the new script 
‘Escape’ and then Double 
Left Click on it to open 
your code editor. One is 
usually packaged with 
Unity.

1

2
3

4
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Adding a script to close your built desktop 
application with the Escape key (2)

The name of the class 
has to match the name 
of the script file, 
otherwise there will be 
an error.

The code in the Update 
function waits for the 
Escape key to be 
pressed and then quits 
the application.

NOTE: Make sure to save 
changes to your script 
before adding it to a 
game object in your scene 
or pressing play.
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Add a script to close your built desktop 
application with the Escape key (3)

1. Drag the Escape 
script directly onto 
the FPSController in 
the hierarchy.

2. Check that the script has 
been added to the 
FPSController by checking 
in the Inspector panel.
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Quick solution for transparency on trees 
and railing textures (1)

1. Left Click on one 
of the features to be 
edited e.g. a tree.

2. Left Click on the 
‘Albedo’ texture 
that needs editing.

3. Unity will automatically find and 
highlight the texture you need to update.

NOTE: The next few 
steps require external 
image editing software 
that can save a PNG file 
with alpha transparency. 
Alternative solutions 
would involve creating 
your own shaders which 
is not covered here.
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Quick solution for transparency on trees 
and railing textures (2)

1. Right Click 
on the texture.

2. Left Click on 
‘Show in Explorer’.

3. Open the file with 
your favourite imaging 
editing software.
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Quick solution for transparency on trees 
and railing textures (3)

The precise process here will depend on the software you use. Suitable choices include Photoshop or the FREE & 
Open Source GNU Image Manipulation Program (GIMP). Generically the steps are:

(1) Import the JPEG image; (2) Select the background pixels by colour; (3) Delete the background pixels; (4) Add 
the background to a transparent alpha channel; (5) Export the file with alpha transparency as a PNG file; (6) 
Save it in the same location as your other model textures.
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Quick solution for transparency on trees 
and railing textures (4)

1. Reselect the object.

2. Drag-and-drop the new PNG texture 
into the objects albedo texture slot.

3. Set the Rendering 
Mode to ‘Cutout’.
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Download a FREE double sided shader

1. Click on the ‘Asset Store’ tab. 2. Search for ‘Ciconia Studio Double 
Sided Shaders’ in the input field.

3. Click ‘Download’ 
and then ‘Import’ 
when prompted.

4. Click ‘Import’ in 
the Import Unity 
Package popup.
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Add the double sided shader to features 
that need it like the trees and railings

1. Click on the 
‘Shader’ dropdown of 
the selected object.

2. From the subsequent popup menus select:
Ciconia Studio >  Double Sided > Transparent > 
Diffuse Bump Cutout
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1

2

3

4

Enhance the look of your scene with the 
Unity Post Processing Stack
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Change project colour space to Linear

1 – 2. In the Menu bar select Edit > Project Settings
3 – 5. In the Project Settings select Player > Other Settings and  change Color Space to Linear

1

2

3

4
5
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Disable Anti Aliasing (to be reapplied later)

In the Project Settings select Quality > Rendering and change Anti Aliasing to Disabled

1

2

3
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Set Rendering Path to Deferred (For Desktop)

1. Find the Main Camera in your scene [in this case it is connected to the FirstPersonCharacter]
2. In the Inspector set the Rendering Path to Deferred [for mobile or AR/VR you would use Forward]
3. Finally Enable Allow HDR and Disable Allow MSAA [MSAA is Multisample Anti-Alising]

1

2

3
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Add Post-process Layer to Main Camera

1

2

1. For the object with the Main Camera [The FirstPersonCharacter] in your 
scene Click ‘Add Component’ in the inspector.

2. Search for and Select ‘Post-process Layer’ from the dropdown.
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Create a new ‘Rendering’ layer

1

2

1. Select the Layer dropdown on the 
object with the Main Camera [The 
FirstPersonCharacter].

2. From the dropdown Select ‘Add Layer’.
3. Type ‘Rendering’ on a blank layer.
4. Update the value for Layer from step 1 

above to ‘Rendering’.

3

4
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Setup Post Process Layer and add Volume

1
2

1. On the Post Process Layer select the 
Layer dropdown and set the value to 
‘Rendering’.

2. Set Anti-aliasing Mode to ‘Temporal 
Anti-aliasing (TAA)’.

3. Add anew Post Processing Volume
component in the same way that you 
added the Post Process Layer 
component previously.

4. Check the tick box ‘Is Global’.
5. For Profile click ‘New’ and Unity will 

automatically generate a new Post 
Processing Profile to which you can 
add effects.

3

5

4
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Try experimenting with the following effects 
and settings

NOTE: Appropriate values 
for post-processing depend 
entirely on the nature of 
your scene and the effect 
you intend.

You may also need to 
adjust lighting and 
brightness levels (SEE NEXT 
SLIDE)
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Experiment with the following values for lighting
1. Go to main 

Directional Light 
and adjust Light 
Intensity

2. Slightly turn down 
shadow strength

3. Go to lighting 
settings

Window > Rendering > 
Lighting Settings
3. Turn up the 

Environment 
Lighting Intensity 
Multiplier
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Easting
717,178.8102 m

Northing
734,518.3045 m

Irish Transverse 
Mercator

(EPSG: 2157)

A spatial reference for geolocating data

Coordinates for the roofline on the south east corner of the 
Convention Centre Dublin (CCD) in ITM (EPSG: 2157) are: 

E: 717178.8102 m / N: 734518.3045 m / Alt: 47.0037 m

See: https://en.wikipedia.org/wiki/Irish_Transverse_Mercator

©OpenStreetMap Contributors

X

717178.8102, 734518.3045, 47.0037

https://en.wikipedia.org/wiki/Irish_Transverse_Mercator
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